1

I tried creating a Folder in a SharePoint 2013 library using REST API. I used the examples provided in Microsoft MSDN site using "folders" end point as well as "add" end point. Folder was created successfully and I can see the folder in UI and also I can navigate to that folder.

Strangely, when I click on "View Properties" of the folder, Name property is blank. When I go to "Edit Properties" window of that folder, Name appears in the textbox and if I click on Save, it starts appearing in "View Properties" window.

Has anyone noticed this behavior? Why Name property is blank even though the folder is created successfully?

1

This issue occured due to October 2015 CU installation and persists not only for Folder content types but also for Videos and document sets.

This can be fixed by installing April 2016 CU update.
URL to download the April 2016 CU:
https://www.microsoft.com/en-us/download/details.aspx?id=51701

MORE INFORMATION:
https://support.microsoft.com/en-us/kb/2920721
https://support.microsoft.com/en-us/kb/3114945

  • I checked the above support links. Under Improvements and Fixes, there is no mention about this specific issue. Have you tried with this installation? Did it fix? – Suresh C Aug 25 '16 at 14:28
  • It is mentioned in the article 3114945. When you select to view all properties of a document set, the display name isn't displayed. – Karvannan Aug 29 '16 at 5:30
0

I too tried creating a folder using REST API as mentioned in MSDN site. I too faced the same issue, folder is getting created but when i view the properties of the folder the Name field is empty, but while editing the same, Name field gets the folder name as value.

To investigate more on it i just tried creating a sample folder through UI directly and tried the same. Here also the Name field is empty in view properties and while editing it shows the folder name.

As there is no difference in the behaviour between the folder created directly and through code, there is no issue in your code. But I am still analyzing on this weird issue.

  • Thanks Nagarajan for confirming this. That's a relief that I am not doing anything wrong, but it is also a concern that it could be a bug! And thanks for highlighting the same behavior when we are creating a folder through UI. That's indeed weird! – Suresh C Jun 14 '16 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.