I'm developing on SharePoint, but this rather seems to be Office question, so I ask this question in this forum.

In Office 2013 there was nice metadata bar, where you could fill different values, now Microsoft decided, that this was too easy for people and moved it to Info tab and mixed up all the metadata fields with fields you want people to fill.

But I seem to have problem with getting user from AD or inserting it to User field in Excel 2016 Person field as following

There is red rectangle at Approver field, showing there is an error

Neither won't work Check for Name (people icon, with check and @ symbol) and dictionary to find a user. Note, that I even tried to copy from Author field and paste to Approver field.

Does anyone have any clue, what might be a problem?

I posted same question earlier here, but there was not much activity

1 Answer 1


My answer is based on my assumptions that you're using a template which is uploaded to the Content Type, and that the Content Type is used on the document library where you see this error.

In order to get the Site Columns connected to the SharePoint document library, you have to upload your template to the document library. The fields in the template connects with the document library site columns. Then download your template again, and upload the recent downloaded template to the Content Type and check the box "Update all content types inheriting from this type?".

Now you're ready to create a new document from the document library, and hopefully all of your site columns in the document library have references to your template.

Try it out.

  • I seem to lose it.. I changed Library settings -> Advanced settings -> Allow management of content types? ->Yes. Now I can upload my own template: Library settings -> Content Type -> Advanced settings -> Edit Template. Then I edited that template, saved to local computer, and then uploaded it to server. But still, I need to first save to get even connected to SharePoint. Am I doing something wrong?
    – Taurib
    Jun 15, 2016 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.