0

I am using InfoPath 2013 with SharePoint 2013. I've created a document library and published the InfoPath form to it. then I've granted the users an Add Permission to that Document Library.

My problem is that users can upload any other documents to that library. by clicking on the "Upload Document" from the ribbon.

Is it possible to fix this. so users will only be able to create documents via InfoPath forms? or is there any workaround to this issue. I am new to SharePoint and InfoPath.

Thanks.

1

There are ways to hide the Upload Button using CSS or JavaScript but this is not recommended. I suggest creating a custom site content type that is associated with your InfoPath Form.

This article provides a step-by-step process of Publishing your InfoPath Form to a Content Type and then associating the content type with a document library: http://www.appvity.com/blogs/post/2013/06/16/How-to-configure-and-publish-InfoPath-to-SharePoint-2013.aspx

Microsoft provides the information here: https://support.office.com/en-us/article/Create-a-SharePoint-library-or-site-content-type-for-your-form-template-ae137cab-bad4-42f0-8105-34f6b1430a70#bm4

Once you have published your InfoPath Form to the library, you can remove the content types except for the one associated with your InfoPath Form: Go to the library from which you want to remove the content type. Click the Library tab, and then click Library Settings. Under Content Types, click the name of the content type you want to remove. Under Settings, click Delete this content type. When you are asked if you are sure you want to delete this content type, click OK.

Using this method, users will only have the ability to upload a document using the InfoPath form.

  • Thanks for your comment. I will try the link and get back to you – ShB Jun 13 '16 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.