I have solution installed in my solution store. I am trying to retract the solution but is stuck on "Retracting".

Solution Tried : 1 . Restart Timer Job services

But when i am trying to add solution and retract solution from Visual Studio i am able to do it successfully.

Any solution ?

7 Answers 7


If your in 2010, you may as well start getting used to Powershell. Open up the SharePoint Management Console and run:

Uninstall-SPSolution YourSolutionName.wsp –AllWebApplications

Remove-SPSolution YourSolutionName.wsp

  • 1
    15 : Powershell command Uninstall and remove does not work. Aug 26, 2011 at 3:49

Make sure that the "Sharepoint 2010 Administration" service is running.


Just run below steps:

  • Run stsadm -o enumdeployments command in SharePoint Management Shell. Look for the JobId string corresponding to your solution. Copy that string.

  • Run stsadm -o canceldeployment -id "you job id string here"

    Your solution wsp will be in Not Deployed state. Now you can easily remove that solution using PowerShell Remove-SPSolution YourSolutionName.wsp or from Central Administration.

  • Check for SharePoint Administration Services in Windows Services. If it is stopped then start it.

You will get more information from here.

  • 1
    stsadm -o canceldeployment -id "you job id string here" did the job, thank you
    Nov 5, 2018 at 19:31
  • stsadm -o canceldeployment -id "you job id string here" also worked for me on SharePoint 2013.
    – Martin D
    Jul 24, 2019 at 16:39

You have to use STSADM commands to remove a stubborn solution. I have been in this situation several times in SP2007. This blog post covers all the steps.

Caveat: I don't THINK that SP2010 has changed the STSADM commands that much, so it should still work in SP2010. Let us know.


Run SharePoint 2010 Management Shell as administrator and then run:

stsadm.exe -o execadmsvcjobs

It will manually trigger the administration jobs.

Reference: http://blog.degree.no/2012/08/sharepoint-2010-solution-stuck-retracting-deploying/


do not run STSADM in Powershell and for some reason it does not return any error and message and is not working

  • with Command Prompt change dir to "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN\STSADM.EXE"
  • (optional) run below command and see the current probably stuck jobs

    stsadm -o enumdeployments

  • stop **SharePoint 2010 administration ** service from services.msc

  • now run below command and all jobs will be run manually

    stsadm -o execadmsvcjobs

results: note the last 2 WSPs which was sucked in my case :

Executing job-application-server-admin-service.
Executing SecurityTokenServiceApplication.
Executing UsageManagerServiceTimerJobDefinition.
Executing job-password-management.
Executing solution-deployment-form-delegation.wsp-0.
Executing solution-deployment-form-supplierregistra.wsp-0.
Operation completed successfully.

If you ever experience that your solution never retracts (or deploys), first verify that the SharePoint Administration Service is running. If it is, restart it and see if that helps.

If your solution is still stuck, start Sharepoint 2010 Management Shell and type in the following command:

stsadm -o enumdeployments

You will see a list of in-progress or pending jobs. Cancel the pending job, either by STS / Powershell commands or through the Solution Management. No point wasting any more time – Sharepoint’s showed you another one of its ugly sides so just run this command to force your solution to be deleted:

Remove-SPSolution -Identity the_name_of_your_solution.wsp -force

There, it’s gone. But now you will most likely get an error message when re-deploying your solution:

This is because after forced solution removal, Sharepoint still believes the feature is installed. You’ll therefore have to deploy your solution from SharePoint 2010 Management Shell with the –force attribute:

Install-SPSolution -Identity the_name_of_your_solution.wsp -AllWebApplications -GACDeployment –force

Note: make sure you match the scope (“AllWebApplications”) of your solution.

If your solution is STILL stuck, stop the Sharepoint Administration Service and manually trigger the administration jobs from Sharepoint 2010 Management Shell:

 stsadm.exe -o execadmsvcjobs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.