1

I have given anonymous access on document library (Not on entire website). by following the below steps i given anonymous access,

  1. Enabled the anonymous access to the Web application from Central Admin.
  2. Enabled the Anonymous permissions for "List and Libraries" from site collections permissions.
  3. Break permission inheritance of document library and given "View Item" permissions for anonymous access.

But whenever i am going to access this document library its asking for credentials.

Should i need to configure something else? please help

  • I got solution..check my answer below. – SP Developer Jun 10 '16 at 6:43
1

Please try to give "View Item" permission on your Document Library anonymous access via Library Permissions.

Kindly check below image for your reference

enter image description here

After doing this your documents have at least viewitem Permission on the document library so it will not ask for credentials for anonymous users.

  • Thanks hardik..But actually i given "View Item" permission on Document Library. but still asking for credentials for anonymous users. – SP Developer Jun 10 '16 at 5:11
0

Finally i did it.
Even If you enable anonymous access to your Lists/Libraries, You still need deactivate "Limited-access user permission lockdown mode" Site collection feature to access list or library. [When this feature is enabled, permissions for users in the "limited access" permissions level (such as Anonymous Users) are reduced, preventing access to Application Pages.]

After deactivating above feature i can able to access my document library with anonymous access. :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.