2

One of the user has started getting following error when he tries to access the site:

Sorry this site hasn't been shared with you

He was able to access site before (been able to access for many months but now suddenly getting access error). All other users are able to access the site.

I have checked permission and this user has CONTRIBUTE access (no one has touched permission either and they are like this for many months)

What could be the cause of this issue and where do I look to fix it?

One thing I can try is removing that user from security group and add again but if this doesn't solve the problem then what do I do?

The user is present in that hidden SharePoint user list which can be accessed as follows:

http://sharepointsite/sites/site/_catalogs/users/detail.aspx

  • anything happen with the user's id, deleted and recreated or in active? also what about the other site collections, is he getting same error? what about a brand new site collection and try to add the user and check it. – Waqas Sarwar MVP Jun 6 '16 at 19:33
  • I have removed user from group and added again and now waiting for user to confirm if it works or not. If it doesn't work then I will try to follow steps mentioned in this thread by everyone. – Frank Martin Jun 7 '16 at 19:21
  • Big question, anything happen with user id? get deleted or locked? and have you tried to give permission on new site collection? – Waqas Sarwar MVP Jun 7 '16 at 19:22
1

If you getting error "Sorry, this site hasn't been shared with you."?

Please check below things.

  1. Might be because of cached credentials from a prior browser session. Try clearing IE cache: Open a new browser window >> Go to Internet options >> In the general tab, click the Delete button >> Make sure that passwords and temporary Internet files are selected. Try different browser such as Firefox!
  2. If you didn't run product and configuration wizard after installation/patch, you may get this error even if you are a site collection administrator. Run it once and get rid of this issue.
  3. Stop and Start "Microsoft SharePoint Foundation Web Application" service from Central Admin >>Application Management >>Manage services on server
  4. If are migrated from SharePoint 2010, or backup-restore/import-exported: If your source site collection is in classic windows authentication mode and target is in claims authentication, You must change classic mode authentication to claims-based authentication
  5. Try clearing the Distribution Cache, Do the IIS reset.
  6. On publishing sites: Make sure you set the Super User & Reader Accounts to a domain account for the SharePoint 2013 Web Application with appropriate rights. http://technet.microsoft.com/en-us/library/ff758656.aspx
  • Are you able to find the resolution? – Hardik Jun 7 '16 at 11:50
  • I have removed user from group and added again and now waiting for user to confirm if it works or not. If it doesn't work then I will try to follow steps mentioned in this thread by everyone. – Frank Martin Jun 7 '16 at 19:21
  • That's Fine... Please provide me updates so i can help you further. & BTW you can give some justice to my answer here. – Hardik Jun 7 '16 at 19:22
0

I have had problems like this but in SharePoint 2010. I could see the user had the right permission but could not access the site.

After playing around, clicking the users, checking permission for that the user, the user would just disappear! (No idea at all why) The fix was easy in that case, just re-adding the user.

My suggestion is try to click the users a few times keep checking the permissions, get back to the group/permission page and see if the user is still there. Also, try to grant permissions directly if the user is member of a SharePoint group or the opposite, add the user to a group. Have or the user tried to login from a different PC?

As Hardik says, try cleaning the user's browser cache/cookies. Sometimes you don't have "power/permissions" to simply go and do an IIS reset or even stopping/starting services, but you could try this in last instance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.