2

I've an infopath form with name and supervisor fields, from yesterday i've been noticing a weird issue that Account ID ( in the name field which is a people picker) doesn't retain its value when a form is re opened after submitting and this issue is only for the Name field however the supervisor field is working fine.

Any work around or any solution would be appreciated.

1

It may be that whenever you are setting the Name field, it has no condition to it, so it will replace the Name with whoever is viewing a completed form. Check to make sure the condition is a required field, so that it won't replace valid data with new data on Form Load.

  • Hi Mike, Thanks for turning up, i've got a work around for this, i've created a new Name field and promoted its values to existing SharePoint fields, so by that way nothing gets changed on the form – Vish Jun 6 '16 at 14:31
0

I have encountered this issue before, too. As a workaround, on submit, I would store the user information within a hidden field on the form. Then, on display/edit, I created a rule that runs on form load that sets the value of the people picker field using the information from the hidden field. For example, on the people picker field I would set the following: DisplayName=Value[name="PreferredName"] AccountId=Value[name="AccountName"] AccountType="User"

  • Hi James, Thanks for turning up, i've got a work around for this, i've created a new Name field and promoted its values to existing SharePoint fields, so by that way nothing gets changed on the form. – Vish Jun 6 '16 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.