2

I'm working on an SP2013 upgrade for a client in which they have two zones configured: 'Default' for general public (internet facing) using http:// and anonymous access enabled, and an 'Internet' zone using https:// for secure content (not anonymously enabled).

In order to automate creation of the Sitemap.xml, we enabled the "Search Engine Sitemap" site collection feature. What we are experiencing now is that the Sitemap.xml and robots.txt URL references point to the Internet zones "https" instead of "http" of the default zone. I've tested that changing the internet zone to http or removing it all together fixes this issue and changes the URLs back to http.

Without having to reconfigure the zones for the web application I was curious if anyone knows of a way to alter which zone or URL is referenced by the Search Engine sitemap job? By default it appears to always reference the Internet zone, even with anonymous access disabled.

Thanks!

0

Interesting find. I did some testing and can confirm what you found. To resolve it I just:

  1. Moved https://www.mycompany.com to any other zone. I tested Intranet and Custom.
  2. Deleted the existing robots and sitemap files.
  3. Performed a full crawl of the default zone http://www.mycompany.com
  4. Regenerated the site map files by force running the SiteMap timer job

As long as it's not in the Internet zone it appears to use the default zone urls.

  • what you're suggesting is to move existing URL of the Internet zone to any other zone, and then remove it. Then clean up the robots/sitemap urls and collapse the internet zone. Then, rely on default zone instead. Is that correct? – Roman Jun 9 '16 at 1:28
  • Put the desired URL in the default zone. The code looks at the Internet zone first (so you could put the desired URL there). Put the less desirable URL in any zone BUT Internet. – Matthew McDermott Jun 9 '16 at 1:49
  • Confirmed that the Microsoft.SharePoint.Publishing .dll contains a hard-coded reference to the SPUrlZone.Internet which will be automatically defaulted if set. – Mark Jun 9 '16 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.