0

I am in need to do some testing in 2013 QA Site Collection but the 2013 QA Site Collection is not in SYNC with the 2013 PROD Site Collection. Is there any easy way to do that without making the PROD site ready only during office hours.

The PROD site has custom workflows and InfoPath forms so what is the best approach and please mention the steps.

  1. Backup-SPSite -Identity "site collection url" -Path "backup file path" Restore-SPSite -Identity "site collection url" -Path "backup file path"

  2. Export-SPWeb [-Identity] "site url or GUID" -Path "backup file path" Import-SPWeb [-Identity] "site url or GUID" -Path "backup file path"

  3. DB Detach/Attach Would this method change the PROD url to QA automatically as the urls are different once the detach attach is done.

Please advise

0
  1. Backup-SpSite By default, the site collection will be set to read-only for the duration of the backup to reduce the potential for user activity during the backup operation to corrupt the backup. If you have SQL Server Enterprise Edition, we recommend that UseSqlSnapshot parameter be used because this ensures a valid backup while it allows users to continue reading and writing to the site collection during the backup.

So if you have enterprise edition then this is option is good.

  1. I dont think import/export is good option.
  2. You can use the DB backup and restore method. it is recommended approach but read-only about the backup, i am not sure.
  • I Tried the Backup-SPSite and got the below error on the top of the screen "We Apologize for any convenience but we have made the site read only while we were making some improvements" .This error wont go off even after the BackUp was completed.I ran Powershell to the make siteLock None but still no change and the site is still ReadOnly. – SavantProdigy Jun 3 '16 at 3:36
  • That's weird... What is ur command? Did u check site collection lock status from central admin – Waqas Sarwar MVP Jun 3 '16 at 3:44
  • I used Backup-SPSite server_name/sites/site_name -Path C:\Backup\site_name.bak and the CA shows the status Locked. I used the below Powershell to Unlock it but no change stsadm -o setsitelock -url "url" - lock none – SavantProdigy Jun 6 '16 at 20:04
  • have you tried to unlock from central admin? – Waqas Sarwar MVP Jun 6 '16 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.