3

I am using this great method for customising my forms, and it has been working perfectly until today.

For some reason whenever I update one of my forms (NewFormExpert.html), it is not updating on the actual SharePoint page. I have deleted the Content Editor which points to the form (../../SiteAssets/NewformExpert.html) and re-added it, but it is somehow still using the old form.

I have literally just made a change as simple as the following for testing this :

    <tr>
        <td>
            Notes<br>
            <span class="hillbillyForm" data-displayName="Comments"></span>
        </td>       
    </tr>

Changed to:

    <tr>
        <td>
            TEST<br>
            <span class="hillbillyForm" data-displayName="Comments"></span>
        </td>       
    </tr>

But when I go and use the form, that field is still entitle Notes. This is yet another irritating anomaly by SharePoint that doesn't seem to make any sense whatsoever.

Does anyone have any idea why my SharePoint site might be using some kind of old or cached version of a file in my SiteAssets? Any help is much appreciated!


Things I have already tried :

  • Hard refresh (ctrl+F5) on the list page and the form page
  • Deleted all browsing history, cookies etc (options -> delete... -> selected all)
  • Renamed the form (this has no effect)
  • Created a new form with the same content etc (SharePoint couldn't find the form)

This leads me to believe that all of my (old) SiteAssets have not only been cached somewhere, but any new files added are not being found, which may suggest some sort of connection issue (I have tried all of the above both on my client machine and the server).

The last thing I want to try is restarting the server. I have been getting the pop-up asking me to restart (following an update I believe), but I have been postponing it as there are still users who need the site. I will restart tonight and post the results here.

  • Try clearing your browser's cache, or refresh the form with ctrl+f5 – Gintas K Jun 2 '16 at 11:28
  • @GintasK Thanks for your comment. I have tried both of those fixes but with no effect. Please see the updated question (it says updated by Community because I cleared my browsing data and it signed me out!) – Bassie Jun 2 '16 at 11:50
  • Are the publishing features active on your site? Make sure that your form is checked in, also have a look at versions – Gintas K Jun 2 '16 at 11:52
  • @GintasK This process was working flawlessly a couple of days ago and I haven't deactivated any features so it should be active - When you say make sure the form is checked in and versions, where can I see these details? is that in SPD? – Bassie Jun 2 '16 at 11:53
  • Yes, find your form in SPD and check if it's checked in, should be an option in the ribbon to check it in, or even if it is, try checking it out and in again – Gintas K Jun 2 '16 at 11:55
2

This was resolved after restarting the SharePoint server overnight.

  • Instead of adding this kind of short answer, you can update your question! – Atish Dipongkor - MVP Jun 3 '16 at 9:43
  • 1
    This is a perfectly valid answer! If a reboot solved the issue, that is the solution – Robert Lindgren Jun 3 '16 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.