0

I have an InfoPath 2010 form published to a SharePoint 2010 library. Every month, project managers use the form to create a progress report on their project(s). Here's the scenario:

Let's say the PM created the first report ever for Project XYZ at the end of July. The form automatically names the posted document based on the name of the project and the report date field contained in the form. So, for example, this report is named Project XYZ 2016-07-30.

The end of August arrives and the PM goes to the library to create the Aug report. Being a smart, efficient person, rather than opening a new, blank form where she'll have to re-enter a lot of information that's the same as last month, she opens the July report, makes a few changes, then Submits. This works fine; a new report titled Project XYZ 2016-08-31 is created, and she sees a "thank you for submitting your report" dialog. She clicks OK.

Here's the monkey wrench: She now sees a dialog that asks "Do you want to save changes to Project XYZ 2016-07-30?" It is asking if the July report she opened at the beginning should be saved with the changes. Because she doesn't read the dialog carefully, and is conditioned to click YES whenever these sorts of dialogs pop up after working in a doc, she clicks Yes. The result is that we now have Project XYZ 2016-07-30 and Project XYZ 2016-08-31 with the same content, the new content for August.

I realize this is a "user error" problem, but no matter how many times I've discussed and demonstrated the need to click NO on that dialog, the majority continue to click YES. I would desperately like to get rid of the dialog altogether.

Is there a way to disable the save pop-up?

Below is a similar issue which got resolved using XDocument(InfoPath 2003) function but its not supported in InfoPath 2010. reference

  • Please add your question here with specific problem domain. Do not just post the link over here, because once the link broken it will be of no use for this community and community users. – Aakash Maurya Jun 1 '16 at 10:43
  • @AakashMorya Thanks for your suggestion.I have written my query as Text. – George Jun 1 '16 at 11:16
  • I reverted my down vote :-) – Aakash Maurya Jun 1 '16 at 11:28
0

I resolved this issue by going to InfoPath File --> Form Options --> Filler Features --> Uncheck "Save and Save As" functionality.

Also in the form Submit button,"Submit Options", I enabled "Show this message if the form is submitted successfully.

After doing this,I didn't get the "Do you want to save changes to existing file" dialog box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.