1

I have a record that is created through a custom webpart and updated through multiple workflows (Triggered on new item and also item update)

The time that the record is created is totally different from the time when record is updated through the SharePoint workflow. It is a difference of 8 hours.

Do note that the first workflow runs almost instantaneously however the time still widely varies (8 hours).

I tried restarting the SP Timer, SP Administration services and also tried restarting the server but to no avail.

The Central Admin web app timezone is the same as the one in the server at the moment, i.e. UTC +8.

Is there anywhere else where I should change my date/time settings, that I had missed?

Thanks.

  • What is the regional time settings in site. – Amal Hashim Jun 1 '16 at 4:06
  • @AmalHashim where do I check those? Thanks. – codeandfootball Jun 1 '16 at 4:10
  • 1
    Under site settings – Amal Hashim Jun 1 '16 at 4:10
  • May i know which option i should choose to view the settings under Site Settings? Thx – codeandfootball Jun 1 '16 at 4:27
  • 1
    Check Site Settings > Regional Settings (Under 'Site Administration') – Ronak Patel Jun 1 '16 at 5:31
0

Answered by both commentators on the question,

Site Settings -> Regional Settings (Under 'Site Administration') is the answer.

Hence in conclusion, there are 2 places to change in SharePoint when changing date/time.

  1. Central Administration
    • Application Management
    • General Settings
    • Default Time Zone
  2. Site Settings
    • Regional Settings (Under 'Site Administration')

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.