0

Ultimately, I am trying to use D3js.org in a SharePoint 2010 CEWP to visualize some data. However, after loading a script I just get a blank web part. I can successfully run jQuery in CEWP so I assume I am setting everything up correctly.

I've narrowed it down to what I think is an issue with SharePoint 2010 displaying SVG images correctly as I cannot display a simple SVG from the below script. I am aware that D3 is dependent on SVG functionality. I am running IE11. Any help would be hugely appreciated and please go easy on the explanation, I'm a bit of a noob. SVG code:

  • Check your document mode using IE developer tool (F12) – Amal Hashim May 26 '16 at 13:05
  • Thanks, looks like SharePoint is using IE8 while other sites are using IE11. Any ideas how to force IE11 in the script, or permanently change it for our SharePoint site? – linesd May 26 '16 at 13:28
1

You can change document mode to IE9. Add below to your master page

<meta http-equiv="X-UA-Compatible" content="IE=9">
  • Thanks very much. Is there any way to force document mode IE9 locally only on one Site Page? Or does this have to be done through the master page? – linesd May 26 '16 at 14:01
  • Master page will ensure the change across all pages. You can also try adding this to the page itself via SharePoint Designer. – Amal Hashim May 26 '16 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.