3

I am trying to create new identity provider for my on-prem SharePoint site that can authenticate windows live id. I have followed the steps explained in this blog.

It ask for a prompt to select login provider when I open the site collection and it correctly redirects to the live id login page. Once I hit login button, it authenticates and takes me back to On-Prem site url at http://<site url>/_trust page. I get following error on this page.

[ArgumentNullException: Value cannot be null.]
   Microsoft.SharePoint.Utilities.SPUtility.FormatAccountName(String provider, String user) +196
   Microsoft.SharePoint.SPGlobal.CreateSPRequestAndSetIdentity(SPSite site, String name, Boolean bNotGlobalAdminCode, String strUrl, Boolean bNotAddToContext, Byte[] UserToken, SPAppPrincipalToken appPrincipalToken, String userName, Boolean bIgnoreTokenTimeout, Boolean bAsAnonymous) +3655
   Microsoft.SharePoint.SPWeb.InitializeSPRequest() +307
   Microsoft.SharePoint.SPWeb.EnsureSPRequest() +400
   Microsoft.SharePoint.WebControls.SPControl.EnsureSPWebRequest(SPWeb web) +324
   Microsoft.SharePoint.WebControls.SPControl.SPWebEnsureSPControl(HttpContext context) +610
   Microsoft.SharePoint.Utilities.SPUtility.RedirectValidateInternal(String url, SPWeb web, HttpContext context, Boolean isTrusted) +320
   Microsoft.SharePoint.Utilities.SPUtility.DetermineRedirectUrl(String urlProposed, SPRedirectFlags flags, HttpContext context, SPWeb overrideWeb, String queryString, String& urlRedirect) +828
   Microsoft.SharePoint.Utilities.SPUtility.Redirect(String url, SPRedirectFlags flags, HttpContext context, String queryString) +101
   Microsoft.SharePoint.IdentityModel.SPFederationAuthenticationModule.OnSignedIn(EventArgs eventArgs) +663
   Microsoft.IdentityModel.Web.WSFederationAuthenticationModule.SignInWithResponseMessage(HttpRequest request) +777
   Microsoft.IdentityModel.Web.WSFederationAuthenticationModule.OnAuthenticateRequest(Object sender, EventArgs args) +522
   Microsoft.SharePoint.IdentityModel.SPFederationAuthenticationModule.OnAuthenticateRequest(Object sender, EventArgs eventArgs) +204
   System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +182
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165

I still do not know what is causing this. I also tried the same with SSL but getting same error.

Any help would be appreciated.

  • Have you followed step 35 of the blog entry? – Nils May 23 '16 at 8:05
  • Yep. I created new Identity Provider, and selected it as one of authentication providers. I know something is missing in what I am doing but no idea what it is. – Kiran Chauhan May 23 '16 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.