0

I am trying to export my encryption key for the 'User Profile service' application in SharePoint 2010 but I keep getting the following error: 'The credentials do not have access to the MIIS database' no matter what I do.

The user I'm trying it with is called 'SHAREPOINT\Administrator' and is a farm administrator as well as a serveradmin in SQL Server. SharePoint, SQL Server and Active Directory are all installed on the same machine so it's a pretty simple setup.

I've tried to export via the GUI and the command-line like this:

miiskmu.exe /e key /u:administrator@sharepoint.local *

and returns the following output

Error: Object reference not set to an instance of an object.

Error Code: 80004003

0

Make sure you are using the ILM service account that runs the MIIS service on the server.

Another thing, you can go to SQL server and check who owns the User profile Sync Database, try to login with that account.

have you tried like this

miiskmu /e a:keyback.bin /u:administrator@sharepoint.local*
  • The owner of the database named User Profile Service Application_SyncDB_86abda723d8746938192c718eecfb6ff is SHAREPOINT\Administrator. I've installed pretty much everything with this account since this is a dev machine and I want to keep things easy. – JonasVH May 19 '16 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.