Just getting started with SP Designer on 2010. Getting the following error.

Unable to open Web site. Possible causes:

  1. The Web server may not have Sharepoint Server intalled...

... and other things that are not the problem.

Anyone ever seen this before?

enter image description here

3 Answers 3


Found the solution, using this article:


Create/modify these registry settings on the client:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters BasicAuthLevel = 2 HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet BasicAuthLevel = 2

Then reboot the client. Tested on 3 different machines, including the sever, and this solved it in each case.


there are a million possible issues but the basics are:

  • Ensure that you are attempting to open the exact url of the site
  • If the site is configured with both a Forms Auth side and an NTLM side, open the NTLM side with Designer
  • Make sure that your IT staff has not locked down the site by disabling access to the _vti_bin folders

If that fails, fire up Fiddler and then watch the traffic when you attempt to open the site in Designer. If you see 403s or anything in the 500s, then the real error details will be in those responses.

  • 1
    To point #2, make sure the IT staff has not prevented access to the web application with SharePoint Designer too, as this is now definable at the web application level in Central Administration. Commented Aug 18, 2011 at 15:28

I just had this problem yesterday. I solved it this morning. My site was set to basic auth. When I set it back to integrated, SP Designer was able to open up my site. Not sure I get the reasoning just yet, but it worked for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.