1

In our internet farm in search server I saw below errors in event viewer. How to solve these issues.

SQL database login for SPL_Config' on instance 'SQL123_SQL' failed.

Additional error information from SQL Server is included below.

Login failed for user 'dc1L\Server1LSEARCH$'.

for the search service application I am using dedicated domain account for search service application service account.

2
  • Is below answer helps you to resolve your issue?
    – Hardik
    May 18, 2016 at 9:19
  • Is that solution works for you?
    – Hardik
    May 19, 2016 at 12:20

1 Answer 1

2

You need to change permission for SharePoint_Config database, you can do as follows:

  1. Login to SQL Server Management Studio under Database Engine using authorized login account.
  2. Expand Security tree and then r-click on Logins > New Login
  3. Click Search and then type your new login account (remember that you must use fully structure domain_name\user_name)
  4. After creating new login account, expand Databases tree, r-click on SharePoint_Config database and then select Properties.
  5. Click Permission setting, select account and then select permission you want to assign for account.

Another Resolution

This error occurs because the SharePoint Timer service cannot log on to the SharePoint_Config database on the instance of Microsoft SQL Server that is used by SharePoint. To deploy Microsoft Dynamics NAV Portal Framework, Microsoft Dynamics NAV Setup creates a SharePoint Timer job through the SharePoint application programming interface (API). The SharePoint Timer must have access to the SharePoint_Config database.

To resolve this issue, add the logon account of the SharePoint Timer service as a user of the SharePoint_Config database. Give role membership to the account db_owner.

3
  • For search service account which permissions need on sharepoint_config database? and seach databases?
    – adilahmed
    May 16, 2016 at 11:31
  • It should be DB_Owner
    – Hardik
    May 16, 2016 at 11:52
  • Is that working for you?
    – Hardik
    May 16, 2016 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.