1

Sharepoint 2013 has double encoding issues where spaces in URL show up as %2520. I understand what this means. = %20 on first encode, then <%> = %25 on second encode, so I end up with %2520. I do not know how to stop the double encoding from occurring. This was not upgraded from another previous edition or migrated, this event just randomly started around two weeks ago. Do you guys have any thoughts?

2

This is a very old bug, from a 2014 Cumulative Update if I recall. Install a newer CU, such as the March or April 2016 which appear to be fairly stable.

EDIT: It was from April 2014/MS14-022: https://thesharepointfarm.com/2014/06/workaround-ms14-022-double-encoding-bug/. Resolved with the September 2014 CU.

| improve this answer | |
  • I looked in the search.clientControls.js files for the encodeURI rules but I was unable to locate them in the exact context they were written in the link above. I appreciate your help and fast response. – Brandon Brewer May 13 '16 at 16:03
  • What patch level are you at? – Trevor Seward May 13 '16 at 16:03
  • 15.0.4797.1000 is the version in settings – Brandon Brewer May 13 '16 at 16:12
  • Are you installing just Security hotfixes or CUs? That is the Feb 2016 round of patches, but it could be simply security patches. – Trevor Seward May 13 '16 at 16:13
  • 1
    I would install the April 2016 or March 2016 CU. – Trevor Seward May 13 '16 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.