0

I am using a SharePoint list as my data source for an SSRS report. I have a multi-choice column named "Office". When a task applies to an office we check the box. Most of the time a task applies to more than one office. I need a way to create a parameter that allows people to select their office and only show the rows in the report that apply to them.

SSRS returns the multi-choice column as a string that looks something like: OfficeA#;OfficeB#;OfficeC#;

When I tried creating a parameter with available values OfficeA, OfficeB, OfficeC, etc and then tried to create a filter that IF Fields!Office.Value is in Parameters!Office.Value that it returns those rows, it returns nothing because the actual value is something like OfficeA#;OfficeC#; and not a single value.

I'd really appreciate help with this.

  • It's been a long time, but can't you trim the string in the expression or through code on the SSRS report? – Trevor Seward May 13 '16 at 14:54
  • I'm not sure how to trim the string... but I was able to do it this way: Step 1: Create a Parameter named Office Make sure you choose Text as the type and allow multiple values Create the available values: Name Value OfficeA OfficeA OfficeB OfficeB OfficeC OfficeC Choose the default values if you want to. Step 2: On your Dataset, right click the dataset name and go to dataset properties Click on filter In the filter expression value choose your field [Office] Choose In as the operator In the parameter field choose [@Office] – Amanda Matthews May 13 '16 at 17:13
  • When you can, make sure to add this as an Answer to your post and mark it as such. – Trevor Seward May 13 '16 at 17:14
1

Step 1: Create a Parameter named Office Make sure you choose Text as the type and allow multiple values Create the available values: Name Value OfficeA OfficeA OfficeB OfficeB OfficeC OfficeC

Choose the default values if you want to. Step 2: On your Dataset, right click the dataset name and go to dataset properties Click on filter In the filter expression value choose your field [Office] Choose In as the operator In the parameter field choose [@Office] This has to be filtered at the dataset and not on the table.. I couldn't get it to work on the table itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.