0

I have a task list with email notification set up. I am getting the email notification once I add a new item to the list. Is there a way that I get the email without title column in the form. I tried making the title hidden in list settings content type but it does not work. Can any one suggest on how to get this. I am currently using SharePoint 2010. Please find the image I have uploaded for better clarity enter image description here

1

I don't think it is possible OOTB, so I would suggest create a custom notification workflow in SPD 2010 and customize it with the columns you want to show.

Another work around (just came now while I am typing - not tested):

Option 1:

  • Create a custom content type inherting from Task and remove the title and see if this works

Option 2:

  • Rename the title field to something else that you can use for something else (like comment or notes) and with the order option put it at the bottom of the list
  • Hi Ahmed, Option 1 when I am trying to create a new content type inheriting from task I don't find an option to delete title. How would I delete the title column for the new content type – SPLearner May 12 '16 at 20:52
  • HI Ahmed even if i renamed the title to something it is showing as Title in the email which I receive. – SPLearner May 13 '16 at 13:05
  • the only thing left to try is my first suggestion, just create a simple workflow and customize its body the way you like! – Ahmed Mahmoud May 13 '16 at 13:08
  • Ahmed I know workflow will work but my client is having a template which is used to create sites..there are 5 of these lists with different names in the template .. so If I create a workflow on each list then I should create 5 workflows on each site we create using this template.We have already 75 sites created based on this template and there are many more to come in future. So this is not a viable solution for the client ..rather I would need to explain them this and ask them to use the default title instead.Thanks for your suggestions. – SPLearner May 13 '16 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.