1

In Document Library setting > Column > Edit Column > I selected "Require that this column contains information:" = YES

Then when I created a new folder, in the library, the requirement is not enforced. What should I do to fix this?

1

Required fields do not carry over to folders by default. If you want that to happen, you have to create a new folder content type, that inherits from folder.

Add this folder content type to your library. Create your desired columns in the library and tell it to add the field to all content types.

Then when creating a new folder, you'll be forced to supply metadata for the folder.

  • tried this; when i created a custom content folder, the option under Additional Column Settings - Require that this column contains information - is greyed out; I can't choose "yes". What am I doing wrong? – Alfatah Kader May 12 '16 at 19:34
  • altered the steps slightly as I was going from memory. I just did it and it worked fine. – Eric Alexander May 12 '16 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.