Our client has article pages where only one name can be selected in the 'Author' column (page properties). I've noticed (as an example) when search results returns one page/article, two authors appear in the refinement. If selecting the author that didn't create the article, in the refinement, it displays a completely different page/article (although it still has relevance to the search query) in the search results.

Why would SharePoint search show a (relevant) page/article but hide another?


After extensive testing, I've worked out that the 'Trim Duplicates' feature is omitting pages that are too similar.

In our test environment (SharePoint 2013) I've created two search results webpart,

  • the first where the 'Trim Duplicates' has been set to 'False' and

  • the second is set to 'True', both weparts use the same Search Box webpart.

All of the documents have been tagged with the metadata 'Stress', and all of the document titles start with 'How do I find out more about ...?'. With the query 'Stress', the two webparts return different number of results, the first 5 results, the second 3. The first webpart returns the correct number of documents tagged with 'Stress', the second doesn't.

SharePoint 2013 used to have an easy option to turn 'Trim Duplicates' off in the webpart settings, but this has vanished since service pack 1 came out. To set 'Trim Duplicates' to 'false' you'll have to export the wepart, here's further information on how to do this:

msdn link

| improve this answer | |

If you look at the metadata is one author the Creator and the other a modifier? If so you can change the behavior of the refiner by either changing the code in the refiner or changing the mapping on the Author managed property.

| improve this answer | |
  • It's not the refiner that's causing the issue it's the Search Results webpart, the 'Trim Duplicates' feature is omitting documents that are too similar. – Haz May 17 '16 at 8:53
  • You can turn that off. – Matthew McDermott May 17 '16 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.