I had created a nice reusable 2010 workflow in SharePoint Designer. It operates on a content type. The workflow had some custom infopath forms included and a bunch of variables.

Recently I ran into the error where it says that

"SharePoint Designer encountered an error generating the task form".

No matter what I do: create a custom task process, approval or feedback process: I cannot publish the workflow anymore. Here is what I have done:

  • Deleting the associated task list won't work.
  • I have started from scratch and cannot publish a new workflow anymore either.
  • Created a workflow on the list itself instead of content type: this doesn't work either.
  • Tested an approval workflow on another list: same problem (see screenshot)
  • I have tested a similar workflow in another site collection and this works without any problems.

error description

How to solve this?

  • I would correlate your error with ULS logs (best if you can connect to specific front end) It should give you some more information why the error occurs (if the issue is on the server side if not it may be something local, have you tried to make those modifications from different machine?) Commented May 25, 2016 at 13:23

5 Answers 5


To Solve this issue activate the SharePoint 2007 Workflows Feature using the following steps:

  1. Open the problem site collection in Browser.
  2. Click on Site Actions > Site Settings > Site collection features.
  3. Activate the feature called SharePoint 2007 Workflows.
  4. Open the problem site collection in SharePoint Designer 2010.
  5. Open the problematic workflow and try to publish again.

for more information please go to this link.


Try to use this tool to remove your unavailable workflow feature from content database http://featureadmin.codeplex.com/

As provided in this answer here

Hope it helps!

  • Thanks Martusha. I disabled and reactivated all the workflow related features, but no difference. I also deleted all custom workflow content types. Commented May 20, 2016 at 10:40

Look for a field called Predecessors in Task Form Fields. In SharePoint Designer 2010 this field is added using existing site column.

Remove the Field Predecessors from Task Form Fields & again publish the workflow. It should published successfully.

Try to use below KB article to resolved same issue if still persist: https://support.microsoft.com/en-us/kb/2572518

  • Thanks for the reply, but none of your proposed solutions help. Besides, I am on Sharepoint 2013 and the KB is therefore obsolete. Commented May 20, 2016 at 17:46

Try to disable and enable infopath form service.


Sometime sharepoint can't fully associate content type to your list internally, So you have to manually associate content type to list for do this

Go to each list where you applied content type and used in workflow.

Go to List Setting -> Advance setting -> enable Allow management of content types and click ok

Now you have List Setting page opens and you have list of content type that is associated with list, Now just click on content type

enter image description here


Since the workflow can be published elsewhere, perhaps it's a local issue. Have you tried clearing SharePoint Designer's cache?

  1. Close SPD2013
  2. Delete everything at %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache
  3. Delete everything at %APPDATA%\Microsoft\Web Server Extensions\Cache
  4. Go to SPD2013 options –> General –> Application Options –> Uncheck the “Cache site data across SharePoint Designer sessions”
  5. Relaunch SDP

from: http://blah.winsmarts.com/2015-3-Clear_SharePoint_Designer_2013_Cache.aspx

This has solved several "odd" issues for me relating to SharePoint Designer Workflows previously.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.