3

I have an APP created in AppStore in Dev and I did move it over to QA for further testing but when I go in and try to add the App throught SiteContent - Add an App - and select the Site Provisioning Tab I get You cant add this App here and clicking on details I get another error stating

Sorry, only tenant administrators can add or give access to this app (Screenshots attached).

  1. I have created that service apps App Management and a Subscription
    Settings Service Application and the services are turned on

  2. I have configured the APP URL

Can you somebody advise what I am doing wrong here. enter image description here enter image description here

3
  • Users can't install an App that is requesting more permissions than they have. What permissions is the App requesting? Commented May 11, 2016 at 3:39
  • @RobWindsor I am logged in as a SC admin and trying to install the APP but receive the below error and that's the error I am getting not more than that. Commented May 11, 2016 at 15:45
  • When the App was developed, the programmer added requests for permissions into the App Manifest. For example, the App might request permissions to read or update Lists in the site where it was installed. What were those permission requests? Commented May 11, 2016 at 15:49

3 Answers 3

6

I know this is an old question, but I just wanted to provide an answer for anyone who may stumble upon it. That error message:

Sorry, only tenant administrators can add or give access to this app.

is very misleading. You can actually have Global administrator role and still get the error. What worked for me was to actually do tenant scoped changes in the tenant admin server. So instead of https://[tenant].sharepoint.com/_layouts/15/appinv.aspx you would use this instead https://[tenant]-admin.sharepoint.com/_layouts/15/appinv.aspx

1
  • 1
    This worked well for me!
    – vinod
    Commented Feb 24, 2021 at 11:27
2

Actually, the users with the full control permission level can install the app. First of all please check if user (who is installing the app) has full control permission or not.

Please refer this article. It suggests to add user explicitly to the Farm Administrator group. But it turned out that this was not enough to solve the issue.
So if it not works then, add your user account explicitly to the Local Administrator group on my machine, reset the IIS and it will work.

Hope this will help you.

0

I'm using SharePoint 2019 and got the same error.

With On-Premise SharePoint one can use the Central Administration URL with suffix _layouts/15/appinv.aspx, so in my case this syntax works http://HOSTNAME:PORT/_layouts/15/appinv.aspx.

I don't have enough reputation that I could just write a comment to Molasses' answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.