0

We are using SP2013, with User Profile Synchronization.

One of our users has changed email. The new email is set correct in his User Profile, but the old email address is still on his "SharePoint-user" ( EnsureUser("dom\user1").Email )

Is there a job that does this? The User Profile Sync from AD seems to work, it runs every night at 01:00. How do I fix this, preferably not only this one time?

  • Have you checked in User Information list? Is it updated with new email address? – Viraj Gorajia May 10 '16 at 12:15
  • The only email information I can see here is when I click the link to the users "mypage" (by clicking at the user in the user information list). That email is correct – Cowborg May 10 '16 at 13:01
  • Go to Site Settings >> people and group >> Open a group>> In Setting menu, click on List Settings >> Click on list view >> Enable work email >> Save it. Now check user email in User Information list – Viraj Gorajia May 10 '16 at 13:25
  • There is the old email(!) ...even though I changed the user´s email the new one with powershell – Cowborg May 10 '16 at 13:49
1

Two things you can try which will not harm anything. First try to run this pwoershell:

Set-SPUser -identity 'dom\user1' -web http://urlofsite -SyncFromAD

Test after this,If still the issue then please run the below command, this will force Sync from UPA to content DBs.

Stsadm.exe –o sync –listolddatabases 0
Stsadm.exe –o sync –deleteolddatabases 0
  • I ran the powerhshell command (Set-SPUser...) and the email changed in the list and it seems to have killed all traces of the old email. Thanks a bunch! – Cowborg May 10 '16 at 14:14
  • glad it resolve your issue. i think i will be more happy if you do the upvote as well....btw i am happy :) – Waqas Sarwar MVP May 10 '16 at 14:15
  • Done! (15 chars) – Cowborg May 10 '16 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.