0

I have a front end server where I am getting login prompt when I access the home page. The weird thing in my SharePoint 2010 site is that it is configured with two languages like English and German, but the login prompt is coming only for one language.

I do not understand what configuration dependency is there for one of the language that, its happening only for one of the language and not work for other?

If anyone has come across this kind of issue and have any suggestion, Please advice.

1
+50

If you're getting a login prompt for a particular page - regardless of which language - it could be due to some files NOT being checked-in + published.

This could be JPG, CSS, or Master Page, Page Layout - or - if the user has put some images in a content editor - and the user needs to AUTH to the page.

Language variations within SharePoint will have different files (behind the scenes) - I'd check to see if any of those are checked out.

  • How to find which image or content is checked-out..there are so many files on home page – Ankit Kumar Jun 1 '16 at 13:05
  • You could look at the page using FIDDLER - and see which one has a 401 - or via the IE Dev ToolBar. Often tricky to work out ! – Chris O'Connor Jun 3 '16 at 1:03
  • Otherwise, look at the page as "Admin" - and see what files are showing - check your SiteAssets for JS, CSS and JPG files – Chris O'Connor Jun 3 '16 at 1:04
  • I couldnt find any check out files images or anything on the page. So i removed the webparts and once I removed all the prompt stopped coming. I re-added them and still no prompts. The issue has been fixed now but the cuse of it is still unclear. Anyhow...may be some other day..thanks all for the help. – Ankit Kumar Jun 3 '16 at 6:20
  • @Ankit: That is exactly what I suggested to do for troubleshooting. Shame you didn't mark my answer. – Suleyman Jun 6 '16 at 7:27
1

Sounds like you have something being loaded on the homepage which triggers login otherwise for a public site you won't expect a login page (which also explains why no login is presented when you view site contents page). Please compare the assets loaded on the homepage between different languages. You can use fiddler or developer toolbar of your browser (chrome works nice, use F12 to open the developer tool and checkout the network tab for 401 return code) and see which request is resulting in unauthorized response (401).

  • There is no error logged in console tab for the other language. The assests loaded are same in both the languages. – Ankit Kumar May 30 '16 at 10:08
  • Have you checked the network tab of developer tools? Please also check "Preserve log" option to keep items in the list in case you are redirected to another page for login. If it's only one page requesting the login then it is most likely related to something on that page. – Suleyman May 30 '16 at 10:18
  • what am i suppose to look in the network tab – Ankit Kumar May 30 '16 at 10:29
  • In the network tab you see a table with columns. On e of the columns is called Status. Check whether you can find a row with status 401. Make sure you are recording otherwise no table will be shown. Here is some info about the network tab: developers.google.com/web/tools/chrome-devtools/profile/… – Suleyman May 30 '16 at 10:41
  • yes i get one row where URL is en/Pages with status as 401. What can be done now. – Ankit Kumar May 31 '16 at 6:59
0

I'm not 100% sure but the prompt will work with your site locale.

Try:

$web =Get-SpWeb <your url>
$web.Locale

And see if that can give you an answer.

  • Dont have powershell in the production server – Ankit Kumar May 27 '16 at 14:47
0

You have to create custom login page for your SharePoint 2010 windows authentication.

You can get the reference from the below mentioned link.

Creating a Custom Login Page for Windows Authentication

You have to pass the parameter (as querystring) on the custom login page for language like lng=en OR lng=ger.

When user is going to open the page using the URL then you need to identify the language from the querystring & change the text according to language.

You can check below link to understand how multilingual SharePoint 2010 sites work.

Supported and unsupported language settings

UPDATED

NOTE :- When a user selects a different language, that choice will be remembered for future visits. There is however no option to make the call the any page in SharePoint without coding in other language.

  • why login page again..this was working before...The login prompt started just few days back for one of the language – Ankit Kumar May 9 '16 at 11:10
  • Is that your custom login page on which you want multilingual controls? – Hardik May 9 '16 at 11:11
  • its a public facing site and the prompt is IE prompt for a SharePoint Home Page – Ankit Kumar May 9 '16 at 11:20
  • Its not happening for other pages in the site..its happening only for one page that also for only one language – Ankit Kumar May 9 '16 at 11:21
  • Login page works before you login to your site. so it is an obvious behaviour. – Hardik May 9 '16 at 11:22
0

I'm not 100% sure, but the language of your login page should be following the language of your browser/windows box.

Try using IE after setting the preferred language:

Internet Options > General > Languages > Add your language and put it at the top.

(All this provided that the alternative languages have been set here: http://yoursite/_layouts/15/muisetng.aspx)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.