0

I have created a workflow where the workflow waits for a single line field not NOT be empty. When this occurs the workflow should continue.

I have two columns:

  1. WebinarTitle - This is a single line field that is initially empty
  2. WebinarTitleCalc - This is a calculated field that is of type YES/NO. The calulation is =ISBLANK([WebinarTitle])

I have an action: "Wait for WebinarTitleCalc to equal NO"

When this happens the workflow should move on. The Webinar Title is updated by an end user.

When I enter some text into WebinarTitle I expect the workflow to continue as the condition is met, but it never goes past this line.

Also, when I enter the calculation =ISBLANK([WebinarTitle]) in the SharePoint site and click save and then open the WebinarTitleCalc column again, the square brackets are always missing. So it looks like this =ISBLANK(WebinarTitle)

Do you know why these two things are happening and could the missing square brackets be the cause of the workflow never advancing?

3

Well, the only change to get this to work is to change the The data type returned from this formula to: Single line of text instead of Yes/No

enter image description here

Then you workflow logic can be something like this:

enter image description here

Hope this helps!

  • Thanks for the help Ahmed, this worked. Much appreciated. – miggitty May 9 '16 at 13:05
0

Instead of Waiting let the workflow start on item updated. In the workflow just check condition if title is not blank and do the action.

If you don't want workflow to act again on that processed item then add a new field and set it to indicate workflow already acted.

Square brackets are used in case if the title has space characters

  • I have already selected the option to start the workflow when a new item is added. There is an email that is sent first, then this check is done, so "Automatically start this workflow whenever an item changed" is not an option. Do you have another suggestion? – miggitty May 8 '16 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.