1

I created a term set called Organization and added a few terms. I then added a column called Organization to a library and set the column to use a managed term set. I chose the Organization term set and kept Allow multiple values to false. I then Grouped the default view by this column.

I was able to add multiple documents to the library, select the organization from the term store and it grouped as expected, awesome. I was also able to add new terms from the library.

Another user viewed this library and instead of seeing the documents grouped by organization as I see it when logged in, it shows "Organization: null" instead of "Organization: myorg". The user is able to add documents, set the term in the column and even add new terms.

Here's another post showing the exact steps I used. Again, works fine for me, but not for any other users. - Group by managed metadata column

  • Only Site Collection Admins are able to see the groupings as expected, but users with Full Control on the site cannot see the groupings displayed. – AtariPixel May 6 '16 at 7:25
1

Found the solution here - Unable to create a site column based on the Managed metadata type?

My issue was resolve by granting permissions to users in the hidden Taxonomy list, which can be browsed by putting this on the end of your Site Collection URL Lists/TaxonomyHiddenList/

I added all users with Read Permissions and now it works as expected for all users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.