0

We have an weird error we cannot find out why this happened. We have some content database that are showing : SharePoint database is in compatibility range and upgrade is recommended

But the what is weird is that those database are at a higher version than our actual SharePoint farm. What could have caused that?

0

1 Answer 1

0

If your database really was a higher than your SharePoint farm, then you couldn't add it--you would receive a schema error. Your databases are just from an older CU, and you need to run the PSConfig on your SharePoint servers to update the schema of the databases to match that of the current SharePoint build.

Use Upgrade-SPContentDatabase: https://technet.microsoft.com/en-us/library/ff607813.aspx

Or use PSConfig.exe, which is the Products and Configuration Wizard present on all SharePoint servers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.