2

I followed the example given on the following page to re-enable some form of decent breadcrumb on a SharePoint (O365) site and all hell broke loose with the navigation.

Essentially the link describes creating a custom master page by making a copy of the existing default master page then removing the style="display:none" attribute from one element and setting the Visibility to true on the next server element.

Simple enough. I did that and set my custom master page as the Default master page.

It worked, showed the breadcrumb but then navigation took a dive showing me the classic and highly valued Sorry, something went wrong message when I try to navigation to sub-sites, site settings

Examples of links that do work:

Examples of links that do NOT work:

If I mess around with the URLs above that don't work by moving certain parts around it does eventually work.

I've reverted the Master pages back to the original, but it's not fixing the navigation issues I'm having.

After reading a bit online it doesn't look like there's a solution for this, which if that is the case is astonishing!

Anyone able to help?

5
  • looks like you are having problems with the Minimal Download Strategy mate. how about disabling it? – Tiago Duarte May 4 '16 at 13:15
  • Check for some missing AjaxDelta tags on your custom master page. Compare your custom master page with the original side by side, see what all components are missing. – Aveenav May 4 '16 at 13:51
  • @TiagoDuarte Are you saying disable minimal download strategy? How would this impact my custom master page but not the default master page which I made a copy of? Note: I literally just removed the display:none and set visible to true on the server control. – Jacques May 5 '16 at 7:47
  • @Aveenav thanks, but as mentioned I did an exact copy and literally only changed those two attributes. Unless Sharepoint Designer does something weird when making copies of master pages? – Jacques May 5 '16 at 7:48
  • Can you post the code with your changes? or a screenshot? – Aveenav May 5 '16 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.