1

I have a problem related alerts. It is working okay with all site collections I have tested except one. Interesting part is when I apply alert in any list of that site it sends mail that alert has been applied successfully but after that for any change nothing happens, I do not receive any mail for any change.

Any help regarding this.

Can we have something on code level by which we can force an alert on particular site.

Thanks in advance :)

  • Is this site collection in the same web app as other site collection you have tested. Alerts can be disabled for a web app. – Ankit Kumar May 4 '16 at 6:33
  • All are in same web application. – notorious May 4 '16 at 6:36
  • Try 3rd party alert&reminder solution, for example JungleBell which is the simpliest. enovapoint.com/sharepoint-alerts-reminders – martusha May 23 '16 at 7:48
0

Please check the permission of that user for the list on which you are setting alert.

The user whom you intended to send alert, should at least have Read permission on that list.

Hope this will help you.

| improve this answer | |
  • User have proper permissions, even owner also not getting alert mail. Thanks in advance for any further details. – notorious May 4 '16 at 8:49
0

Alerts are sent by timerjob "Immediate Alerts".

If you have multiple servers SharePoint farm, check that all servers that have service "Microsoft SharePoint Foundation Web Application" enabled have permission to sent messages via smtp. You can use telnet to check.

"Microsoft SharePoint Foundation Web Application" service should be enabled only on WFE servers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.