1

Until today, the content creator for my company's intranet would use the add new page button in the gear button drop down to create new pages.

Today that button disappeared and none of us had changed any settings on the site. Also, it became impossible to add new pages to the page library.

After turning the site publishing feature off then back on, I can now create new pages for the pages library, but am unable to change the page layout. Also, the add new page button is still missing.

This is a completely new issue for me and I am wondering if anyone has any advice?

0

Take a look at your Page layouts and Site templates information under Site Settings > Look and Feel (your site url + /_layouts/15/AreaTemplateSettings.aspx) and see what layouts are available to be used in the site.

Also, check to see if the SharePoint Server Publishing Infrastructure feature is activated at the site collection.

Does your ribbon look like this: (can you take a screen shot of what you're seeing?) enter image description here enter image description here

  • The SP Server Publishing Infrastructure feature is activated. Also, there are several page layouts available. This issue appeared today and no one has made any modifications to any settings on the farm. – John S May 3 '16 at 20:11
  • Is this a 2010 site or a 2013 site? The question is tagged 2013 but you refer to the Site Actions dropdown which doesn't exist in 2013. Are you talking about the gear icon? I'm only asking because what you describe is similar to what our users noticed after we upgraded to 2013 from 2010. It almost sounds like the page is no longer a publishing page – sween_sp May 3 '16 at 20:24
  • I thought the gear icon was the site actions menu? Anyways, its 2013. I am referring to the gear icon. – John S May 3 '16 at 20:25
  • You mentioned you couldn't edit the page layout but you could now add a new page. Can you edit the page layout for the new page that you add? – sween_sp May 3 '16 at 20:29
  • Nope. The ribbon has less options than it did before. They arent greyed out either. They have been removed. – John S May 3 '16 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.