1

I have successfully configured Project Server Service Application on my SharePoint 2013 machine, I am using SharePoint 2013 SP1 and SQL Server 2014 Enterprise.

When I create a Project Server Web, Database provisioning fails and I get the following error in Event Log

Failed to provision site PWA with error: 

Microsoft.Office.Project.Server.Administration.ProvisionException: Failed to provision database.
Database provisioning failed. The database WSS_Content_ProjectWebApp contains a non project schema and cannot be used. ---> Microsoft.Office.Project.Server.Administration.ProvisionException: Database provisioning failed. The database WSS_Content_ProjectWebApp contains a non project schema and cannot be used.
   at Microsoft.Office.Project.Server.Administration.PsiServiceApplication.EnsureProjectServiceDatabase(ProjectProvisionSettings provset, String collation, ProjectDatabaseStateType& originalDatabaseState)
   --- End of inner exception stack trace ---
   at Microsoft.Office.Project.Server.Administration.PsiServiceApplication.EnsureProjectServiceDatabase(ProjectProvisionSettings provset, String collation, ProjectDatabaseStateType& originalDatabaseState)
   at Microsoft.Office.Project.Server.Administration.PsiServiceApplication.CreateSite(ProjectProvisionSettings provset)
  • Are you referencing an existing database by accident? – Mike May 3 '16 at 18:02
  • No, I am creating new one from Project Server Service Application's page – Sukhdev Zala May 3 '16 at 18:16
  • If you specify the database to PWA_TEST_CONTENT, what happens? – Mike May 3 '16 at 18:22
0

This error message "Database provisioning failed. The database WSS_Content_ProjectWebApp contains a non project schema and cannot be used." is guiding me that you are using an existing database.

Please make sure when you provision a new PWA, you should create a new database.Looks like this "WSS_Content_ProjectWebApp" this db is faulty.

Try a different name and then try to provision it.

0

in my case provisioning error was related to Web Service Root application pool stopped in some servers in farm in IIS

1- first run below command to see some error saying

Upgrade-SPProjectWebInstance -Identity "http://epm.domain.com/pwa"

2- if in my case you see similar below error just go to server and find related application pool and start it and try again

Upgrade-SPProjectWebInstance : The HTTP service located at
http://servername:32843/SecurityTokenServiceApplication/securitytoken.svc is
unavailable.  This could be because the service is too busy or because no
endpoint was found listening at the specified address. Please ensure that the
address is correct and try accessing the service again later

3- after this step Upgrade-SPProjectWebInstance ran successfully and provisioning error resolved

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.