1

I am trying to clean up issues on SharePoint 2013. My Farm is an in place 2010 to 2013 upgrade. In Central Admin under "Servers in Farm" (/_admin/FarmServers.aspx) my Server is reporting that I have to do an upgrade. However, clicking on "Upgrade Required" doesn't get me anywhere.

I went into PowerShell and ran this command: "stsadm.exe -o localupgradestatus". I got the following error:

Unhandled Exception: System.TypeInitializationException: The type initializer for 'Microsoft.SharePoint.StsAdmin.SPStsAdmin' threw an exception. ---> System.Bad ImageFormatException: Could not load file or assembly 'Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its d ependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded. File name: 'Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'
at Microsoft.SharePoint.StsAdmin.SPStsAdmin..cctor()

I ran the "Configuration Wizard" and reran the PowerShell command, I still get the same error.

Any Idea how to fix this?

enter image description here enter image description here

  • 1
    Have you checked the following..central admin > upgrade and migration > Review database status...on this page see if any database complaining about it? – Waqas Sarwar MVP May 2 '16 at 17:07
  • also try to run the get-spproduct -local – Waqas Sarwar MVP May 2 '16 at 17:09
1

Sharepoint 2010 to SharePoint 2013 inplace upgrade is not supported. I'd try to carve out a separate server for the time being in order to install SharePoint 2013 and pull over your content databases after you create a farm.

https://technet.microsoft.com/en-us/library/ee617150.aspx?f=255&MSPPError=-2147217396

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.