0

I was trying to add conditions / Actions to my SharePoint workflow through SP Designer 2010 and realised they had gone missing. I re-installed the designer to no avail. Any idea what is wrong?

I am trying to add those to a List Workflow. Screenshot below. Thanks.

enter image description here

  • Were you able to find a solution to this problem? I have the same issue and am looking for any guidance I can get. Thanks Shawn – Shawn Keizer Oct 13 '16 at 22:44
  • Try clearing your SP Designer cache. I think it is at C:\Users\[your account]\AppData\Local\Microsoft\WebsiteCache. Just delete all of the files in it and then reopen Designer – T0t3sMcG0t3s Oct 13 '16 at 22:48
  • You will have to close designer while doing that btw – T0t3sMcG0t3s Oct 13 '16 at 22:49
0

I had this problem in SP Designer 2013 when trying to edit a 2010 platform workflow on a SP2013 server. It turned out to be a missing WSS.ACTIONS file. On the server, check the hive \TEMPLATE\1033\Workflow folder for this file. It's an XML file containing the conditions and actions available. If not found, it cannot display the actions.

  • Need to add that it doesn't take effect immediately. You'll need to restart the server or wait overnight for the background processes to refresh (cache?) – Phil Jun 29 '17 at 16:03
0

This is a known bug in SharePoint designer. Opening up a SharePoint workflow an seeing all the conditions blank has given me a lot of consternation!

Step 1: Make sure SharePoint Designer is patched to the latest version. As of this writing the install steps are (for 32-bit version):

  1. SharePoint Designer 2013 Installer:
  2. Patch 1: Service Pack 1 for Microsoft SharePoint Designer 2013 (KB2817441) 32-Bit Edition
  3. Patch 2: Update for Microsoft SharePoint Designer 2013 (KB3114721) 32-Bit Edition

After you have installed and patched SharePoint Designer 2013 the version will be: 15.0.4849.1000. You can verify this by opening SharePoint Designer and going to: File Menu >> Account >> About SharePoint Designer

Step 2: Clear your SharePoint Designer Cache:

  1. Close SharePoint designer if it is open
  2. Using Windows explorer, go to: %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache
  3. Delete everythig inside that folder
  4. Now go to: %APPDATA%\Microsoft\Web Server Extensions\Cache
  5. Delete the contents of that folder as well

Step 3: Optional: stop SharePoint Designer from using its cache:

  1. Open SharePoint Designer
  2. Navigate to the “File” menu. Then go to Options >> General >> Application Options
  3. On the “General” tab, under the “General” heading, deselect “Cache site data across SharePoint Designer sessions”
  4. Press OK to save the changes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.