0

Objective:

Send a notification email to users when blog post is first approved but NOT on subsequent edits/approvals. Using a 2010 wf triggered by an item change.

Process:

Added a yes/no helper field ("email sent") to check if an email has already been sent.

Result:

Workflow runs but no email is sent. No error.

Workflow:

When I tried that I got a validation error about "An IfElseActivity must have at least one child of type IfElseBranchActivity.)". Wf still runs but doesn't send email.

enter image description here

enter image description here

2

It should be something like below:

Workflow steps

The way it is right now, I don't think the workflow even enters the "then email..." activity.

Of course, you would want to place the second condition with an "else" statement, but with MSPaint I thought of keeping it simple.

  • Thanks - tried that and updated the question with result. – matt Apr 30 '16 at 13:15
  • Remove the second if condition. Else statement itself is sufficient. Your new workflow needs to publish before it works. – Nisarg Apr 30 '16 at 13:17
  • See updated image. Still no luck. – matt Apr 30 '16 at 13:59
  • Does that allow you to publish the workflow? Are you entering the workflow with "email sent?" set to No? – Nisarg Apr 30 '16 at 14:12
  • Yes, the default value for that field is "no". it seems to run but no email. – matt Apr 30 '16 at 14:17
1

I found the answer here:

http://www.networksteve.com/enterprise/topic.php/How_to_fix_this_Designer_Workflow_error/?TopicId=91458&Posts=3

In short there was a "hidden" else if condition from a previous attempt and you have to hover over each section in the wf and delete anything that's empty. Not at all obvious and not the best of designs, but pretty typical of Msft products.

Thanks for helping @Nisarg!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.