1

I am working with a list integrated into my SharePoint Add-in. Normally, to remove the title column, I would go into the list settings menu and work with the column that way. The issue is that from the add in, the list settings menu is not available. I instead went to the XML list definition where I set the title field to required = false. However, that change is not reflected in the actual list. When I run the add-in, the list will still not let me add an item without a title value.

Here is the xml for the title field:

     <Field ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" Type="Text" Name="Title" DisplayName="$Resources:core,Title;" Required="FALSE" SourceID="http://schemas.microsoft.com/sharepoint/v3" StaticName="Title" MaxLength="255" />

Has anyone else had this problem?

  • Have you tried adding the Overwrite attribute? – T0t3sMcG0t3s Apr 27 '16 at 22:23
1

site settings > advanced settings > allow content management (yes) site settings > click on content types (may be list/library name) now click on title column and hide the column.

  • The list is contained within a SharePoint add-in, there is no settings menu. It needs to be done programmatically. – cmoody4 Apr 27 '16 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.