1

I am unable to publish a SharePoint 2010 workflow due to the following error: “Could not publish the workflow because the workflow configuration file contains errors.”

Several posts suggest deactivating and then re-activating the Workflow Features. https://social.technet.microsoft.com/Forums/sharepoint/en-US/8333b2c0-ca4d-4e5f-a1bc-a37926d530bd/sharepoint-designer-workflow-error-errors-were-found-while-compiling-the-workflow?forum=sharepointgeneralprevious

However prior to doing this I get the standard warning "If you deactivate this feature, any user data or customisations associated with this feature might be lost. In addition, any active features that depend on this feature might fail to function."

Am I safe to deactivate this and re-activate. I don't want to impact the production environment.

bumped to the homepage by Community 23 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • Is this the first time you try to publish a workflow to this site? Has it worked before? Do you have any running workflows in the site? Is it a big workflow? – Christoffer Apr 26 '16 at 15:17
  • in sharepoint 2010 or sharepoint 2013? – Waqas Sarwar MVP Apr 26 '16 at 15:46
0

Any running Instance of the Workflow will be lost. i think it is not best practice to deactivate it in Production farm.

If you have lower environment then try to reproduce the issue over there. also have a look into this post SharePoint 2010: 3 of 6 Workflows "Failed on Start". SharePoint Designer Workflow Works Fine?

http://sharepointerros.blogspot.com/2011/08/errors-were-found-when-compiling.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.