2

Environment : Sharepoint Foundation 2010

I created a helpdesk list which contains a default content type.

When I go to the list settings, I cannot :

  • Delete any field already created at the same time than the list,

  • Change the column ordering (and I also want to), I don't have the link below the table of columns.

Why I cannot do that ?

I prefer modify something, even recreate a content type, rather than delete my list. But if there's no other way...

  • 1
    I guess its necessary that you can keep your items? Simply modifying the view is not enough? You want the fields to be removed and not just hidden? If yes you will likely have to create the content type of your use case and migrate the items. – Mx. Apr 26 '16 at 14:55
  • It is not a problem if I delete all the items. But it's a problem if I delete my list, because a workflow is associated to it. How can I create a content type ? I can't see it in Designer – Slabre Apr 27 '16 at 6:51
  • 3
    support.office.com/en-us/article/… – Mx. Apr 27 '16 at 8:06
  • Thank you, I've recreated a new Content Type and it works! – Slabre Apr 27 '16 at 9:33
3

Go to List settings -> under Content Types heading all the content types the list is using are listed

Click any content type, this will list all the columns and click the column you will be able to delete the column by using Remove button at the bottom (don't worry it will not delete from the parent content type - it will just delete the column from list association)

Reordering is also available when you click the content type - at the bottom there is a link named Column order.

UPDATE

Since those are default columns which stick to the list type you are using, you will have to create your own content type.

  • I cannot delete the column, I don't have the Remove button, just "OK" and "Cancel". However, I can reorder the columns. – Slabre Apr 26 '16 at 14:46
  • Than it is probably the default column which sticks with the list type you are using, in that case you will have to create your own content type and migrate the items as suggested by Mx. On the other hand if Hiding the column from all forms and views works for you, you can simply hide the column – Arsalan Adam Khatri Apr 26 '16 at 15:35
  • Can you edit your answer stating recreate a new Content Type ? I'll mark it as a solution. – Slabre Apr 27 '16 at 9:35
  • @Slabre updated – Arsalan Adam Khatri Apr 27 '16 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.