1

I created all my terms sets in my development environment, but when I publish in another environment is giving the error image. I went up the base "managed service metadata", but still meeting with the error "error loading navigation term SET NOT found" Does anyone know how to restore the term sets that made the development environment?

enter image description here

  • You selected to use Managed Navigation for the Global Navigation, but have you actually selected a term set under the **Managed Navigation: Term Set ** section? If yes, try a CTRL + F5 to refresh the web browser cache. – Mihail-Florin Popa Apr 22 '16 at 20:45
0

As you have explained, the terms are setup on your Dev environment, and you are trying to use them on a different environment. Meaning you need to have your terms setup on this environment as well, before you could use them.

The easier way is to recreate only the subset of terms you require on the target environment.

However if you wish to carry all the terms from Dev to your target environment, you could refer this answer: How to migrate managed metadata to different environments

The accepted answer is:

  1. remove the MMS SA from your destination farm
  2. restore the db to your destination sql
  3. create new MMS SA using the restored db name
  4. Voila

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.