2

In SharePoint Online, I have created a reusable workflow (2010-mode) attached to a content type (task-based) and use a retention policy on that content type that fires off said workflow based on a custom date column + 1 day.

The only action in the workflow is a send mail action. Everything is working as expected, part from the fact that I can't fetch the correct value for the ootb due date column in the mail. I have tried every other date column in the content type (all custom) and they get the correct date value but when I use the mf ootb due date column I only get "1/1/0001 12:00:00 AM" as a value.

Every item has a value in the due date column, so it is not empty, null or something like that. I have switched between standard and friendly format with no luck.

I have manually changed the value in the due date column to different dates (including "today") with the same result.

I know I can create a new date column and name that column something similar and all is fine and dandy but right now that is not an acceptable solution.

Anyone out there having the same problem with the due date column?

  • The Due Date is a required column and if I make the exact same workflow as a list workflow the due date value is correct. Since there will be 200+ lists each year that is not an option either...yet ;) – Jonas Malmberg Apr 23 '16 at 9:11
0

Due Date column is a required column? 1/1/0001 12:00:00 AM will come only when the field is empty. Try setting it as required column and then check.

  • The Due Date column i a required column. – Jonas Malmberg Apr 23 '16 at 7:06
  • On which content type you have the workflow.. Check the Date field in there.. Is it taking some default value? – Ankit Kumar Apr 26 '16 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.