0

I was wondering why the navigation menu in team sites looks different on different pages/sub-sites.

To give you an example:

How it should look site-wide: (It seems that this menu is only appearing on https://*.*******.*/_layouts/15/settings.aspx)

enter image description here

How the main page appears: enter image description here

Is there any way I could fix this so that the menu in the first image is displayed site-wide? The menu in the first image is only view-able in some sub-sites but not the main page for example.

Also is it possible to remove the 'National Statistics Office' (site name) from the navigation bar?

EDIT: Global Navigation Menu

enter image description here

This is the master page settings page (everything by default except the alternate css).

enter image description here

All sub-sites except the main site have the navigation menu correct. It seems that only the main portal is not displaying the navigation menu correctly and all the sub-sites are inheriting navigation from the parent site.

4 Answers 4

0

For your Q#1, check to see if it's using different master page on the root site. Check for any errors in the console. From your screenshot, it looks like the all the menu items are present but flattened out (i.e no dynamic drop down navigation) Switch to original master page for one of the two master pages(custom or system) see if it works.

For your Q#2,

If you look into the html output (use Firebug or IE tools), you'd see how SharePoint constructs the structured navigation. The root site becomes the first anchor child and all other are in turn the children of li with class 'static'. Add the following CSS to your stylesheet 'style.css':

div.ms-core-listMenu-horizontalBox > ul.ms-core-listMenu-root > li.static > a {
    display: none;
}
4
  • I have all sub-sites inheriting navigation from the parent site and it's working. The only problem is that the parent site itself is not adhering to the navigation structure!
    – Brian
    Apr 22, 2016 at 7:43
  • Did you check console for any error logs?
    – Aveenav
    Apr 22, 2016 at 13:28
  • Is this security trimmed and spanning across site collections? I am direly in need of a solution for implementing a security trimmed, cross-site collection navigation menu that works for SharePoint 2016.
    – Web User
    Dec 12, 2017 at 19:06
  • take a look at: eschrader.com/2017/05/24/…
    – Aveenav
    Dec 13, 2017 at 20:39
1

You can remove Page Title 'National Statistics Office' (site name) using below custom CSS code

/* custom css to remove the page title */
h1.ms-core-pageTitle { display:none; }

for the menu, can you please explain more as both images look like same so its hard to identify the problem.

As i understand here that you want same navigation in all subsites from main site.For that you can follow these steps mentioned in below location.

Configure Global Navigation in SharePoint 2010

It is for SharePoint 2010 but it will work same in SharePoint 2013 as well.

8
  • My bad.. uploaded wrong image. Updated question with proper image!
    – Brian
    Apr 21, 2016 at 7:23
  • Please check my updated answer. If you need something else than please let me know.
    – Hardik
    Apr 21, 2016 at 7:24
  • It seems that they already are in the right order, however, the menu is not the same site-wide.
    – Brian
    Apr 21, 2016 at 7:33
  • With regards to removing the site title from the nav bar.. which CSS file do I need to modify?
    – Brian
    Apr 21, 2016 at 7:34
  • 1
    The code above is the css part which you should add in a Script editor but you should put Style Tag in both side: <style>h1.ms-core-pageTitle { display:none; } </style>
    – Shaghayegh
    Apr 21, 2016 at 7:35
0

For Setting the navigation same as parent site you can go to Navigation link in Site Setting in each sub site and chose inherit from parent site navigation and it will work perfectly. enter image description here

2
  • That option is not clickable. Is there a logic behind this?
    – Brian
    Apr 21, 2016 at 7:39
  • That option would only apply to sub-sites.
    – Aveenav
    Apr 21, 2016 at 20:10
0

As you said in question, the navigation appearing correctly on Setting page but not on main page, then make sure that Site Master Page and System Master Page are same.

enter image description here

There might be possibility that, System Master Page is using actual Navigation and Site master page is using some custom navigation

1
  • @P S kindly see my updated question with images.
    – Brian
    Apr 21, 2016 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.