0

Not able to install provider hosted app due to apphost url different at production environment. Please help me in this regard.

1

The reason behind this may be you do not have registered your app with appregnew.aspx with proper domain and redirect url.

If you have done this then another possibility is that you do not updated your web.config and AppManifest.xml file with proper ClientId and ClientSecret key.

If this also done then while packaging your app you didn't provided ClientId.

Please verify all of the above criteria before installing.

And if you give what error you are getting then it will be more helpfull to provide solution.

If your apphostweb url is different then you can pass the url directly into your AppManifest.xml. it will work.

If you are installing your app on another server then make sure you register your app with appregnew.aspx on production server and update that client id and client secret key in your app and then package the app and install on production server.

Correct me if i am not getting your problem.

Thanks.

| improve this answer | |
  • .app file is installing on my machine. when i give it to any other machine lets say to production environment. when i am trying to installing app over there. i am not able to install because my app domain is different and production app domain is different. so want deployment strategy to install app over there. – rwaykos Apr 19 '16 at 17:49
  • I updated my answer with few more description. I hope it will help. – Aakash Maurya Apr 19 '16 at 17:54
  • Thanks @akash But i want to Automate app installation at production environment. – rwaykos Apr 19 '16 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.