0

This seems like a Sharepoint bug... I created a custom list based on a custom content type. Those fields all show up correctly.

Additionally, I added a custom lookup field to the custom list, to look up to another custom list (which also uses a custom content type - likely irrelevant, but you never know).

IF I do not specify "Allow Blank Values": enter image description here

Then the fields show up on the "New Item" form: enter image description here

However, if I uncheck "Allow blank values?": enter image description here

Then the fields do NOT show up on the new item form! enter image description here

I EXPECTED this:

enter image description here

0

Your new field needs to be a part of the content type to be displayed on the new/edit forms.

I think the easiest solution is to go to list settings (on UI), find the content type (Category Factory Implementation Plan List Item), click on it to open its customization page. Click on "Add from list columns" link on the page, and add the "Opportunities" column there. Once you do this, you will get the form correctly showing the new column.

A better way to do this might to create a new site column, then add it to the site content type and then update the list content type, by adding the site column.

However I am not sure how to do this on SP Designer.

  • It does not seem possible to add a list as a field to a content type. The field is a multiselect from a related list. – Alexx Apr 15 '16 at 20:14
  • You don't have to add the list in the content type (which you can't). You need to add the list column opportunities to the list level content type. Read this to understand about list level content types: blog.furuknap.net/… – Nisarg Apr 16 '16 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.