I'm using MOSS on the server and have Office Enterprise 2007 and IE9 on the client. In all libraries, I can only upload a single document at a time; the multiple document upload option is not presented. The problem seems to be specific to my own workstation.

Has anyone got an answer for this?

UPDATE 08-11-2011:

This seems to have been already answered:

What are the client side requirements to enable the "upload multiple files" link?


I just Binged it to be sure, but the control is only available if you have Office installed on the workstation, as it uses an ActiveX control provided by Office.

Since you have Office installed, I'd suggest doing a repair on the installation to see if that fixes it.

  • I tried it Marc, and am still having the problem. Also ruled out 32 vs 64 OS issues. – IrishChieftain Aug 10 '11 at 22:31
  • At least I thought I did! :-/ – IrishChieftain Aug 10 '11 at 23:22

I found a solution:


My machine is 64-bit and this problem presents itself with the 64-bit version of IE9. When using the 32-bit version, the multiple document upload option is present.


  • hmmm...I have 64bit OS and IE9 and I can multi-file upload just fine. Had to enable the add-on but it worked after that. – Rob D'Oria Aug 10 '11 at 23:27
  • That is so weird. Not seeing the multiple document upload option seems to be a symptom of a whole range of different issues... – IrishChieftain Aug 10 '11 at 23:28
  • 1
    That sounds right to me - you have to use the 32-bit version of IE. The problem is with the 64-bit version of IE. Doesn't matter how many bits the OS uses. – SPDoctor Aug 11 '11 at 0:10
  • 1
    64 bit versions are only fully support viewing site.not the collaboration feature so it makes sense. – Jesus Shelby Aug 11 '11 at 13:39
  • @Jesus, +1. I've added a link relating to this in the original question. – IrishChieftain Aug 11 '11 at 15:37

If it's only occurring on your workstation then that's good...that eliminates a few potential problems.

I'll start with most likely causes and go from there:

1) IE is not configured to allow ActiveX...Tools > Internet options > Security. Would add your SP site to the Local Intranet or Trusted Sites Zone for starters if it's not there already. After that enable the relevant ActiveX settings.

2) The upload ActiveX control is disabled in IE: https://skydrive.live.com/view.aspx/Technology/Upload%20Multiple%20Documents%20Grayed%20out%20because%20the%20ActiveX%20control%20is%20disabled%20in%20IE.docx?cid=6f40fb61d28cf147&sc=documents

3) Repair Office 2007.

I actually experienced Number 2 when I upgraded from IE8 to IE9...the upgrade process disabled quite a few of my add-ons. It's not clear in the doc I refernced, but you get to it Tools > Manage add-ons. You may need to select "All add-ons" from the Show dropdown to see it.

  • Your diagram mentions stsupld.dll and some googling mentioned owssupp.dll. Cna you shed any light on whether I need to install one of these in my Office folder? – IrishChieftain Aug 10 '11 at 22:46
  • 1
    It should be in C:\Program Files (x86)\Microsoft Office\Office12 ...assuming your running a 64-bit OS. Is it showing up in the manage add-ons dialog and if so it is marked as Enabled? – Rob D'Oria Aug 10 '11 at 22:56
  • You're right, they were in the X86 folder. I copied them over. Either way, they're not showing up under all add-ons. Do I have to register them and how do I do that? – IrishChieftain Aug 10 '11 at 23:01
  • You don't need to move them...that's where they belong. If they aren't showing up in the list of add-ons then Office isn't installed right/fully. Did you select "Add add-ons" from the Show dropdown on the Manage add-ons dialog? – Rob D'Oria Aug 10 '11 at 23:10
  • Yep, I found the source of the problem, see my answer. Thanks for your help Rob :) – IrishChieftain Aug 10 '11 at 23:19

The multiple upload options is driven by and activex control. Check your ie settings ensute you van run activex controls. If settings are fine you will want to check your office install. verify you installed the sharepoint componets (usualy selected by default). If its installed try doing a repair.

  • All active x option either enabled or set to prompt, still no luck. Is a reboot required? Tried opening new browser after configuring but still no go – IrishChieftain Aug 10 '11 at 22:35

SOLUTION: you are on x64 bit machine so solution is to use 32bit of Internet Explorer you are using the wrong IE shortcut.

There are different IE versions you have on 64bit, you will see..
•Internet Explorer (64-bit) - won't show any sharepoint add-ons and wont work
•Internet Explorer (No Add-ons) - won't show any sharepoint add-ons and wont work
•Internet Explorer - only this will show sharepoint add-ons and will work so basically make sure you always use this version of IE

So all you need to do is use correct (32bit) shortcut of IE and it will work. no repair, no reinstalations etc! :)


Does the ActiveX control display/is ActiveX blocked in the Windows7 environments?

  • No ActiveX is not blocked! – neo269 Aug 4 '10 at 15:25

What errors do you get. Is this an issue where the windows explorer window doesn't open. Check the path to the folder in which you are trying to add docs. If you exceed the 256 character limit(I think this is the limit) in the path I find that it wont open.

  • Its within 256 chars limit. When I click on 'OK' button after Drag & Drop. The screen shows updating but nothing happens. After few minutes it shows 'Failed!' – neo269 Aug 4 '10 at 15:27
  • 1
    What file types and sizes are you trying to upload? Are there any special characters in the filenames that shouldn't be there (such as plus ampersands)? – James Love Aug 4 '10 at 16:18
  • No, File does not have special chars. I think the issue could be because of Windows 7 :) – neo269 Aug 6 '10 at 6:04

I am able to solve the issue by using 'Explorer-view' in Shared Docs. Its a workaround though. Default upload is still not working. -saumil


For IE11 you need to run the site in Compatibility mode or the option to upload multiple documents will be missing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.