0

I'm trying to set DenyAddAndCustomizePages property to 0. I execute the following in SharePoint Online Management Shell:

Set-SPOsite https://mycompany.sharepoint.com/ -DenyAddAndCustomizePages 0

But I receive the following error:

Set-SPOsite : Property set method not found. At line:1 char:1 + Set-SPOsite https://mycompany.sharepoint.com/ -DenyAddAndCustomizePag ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Set-SPOSite], ServerException + FullyQualifiedErrorId : Microsoft.SharePoint.Client.ServerException,Microsoft.Online.SharePoint.PowerShell.SetSite

NOTE: mycompany is a placeholder for the real company name.

If I execute the following:

 Get-SPOsite https://mycompany.sharepoint.com  | Format-List

I get the output:

LastContentModifiedDate           : 17/12/2015 07:33:40
Status                            : Active
ResourceUsageCurrent              : 0
ResourceUsageAverage              : 0
StorageUsageCurrent               : 0
LockIssue                         :
WebsCount                         : 0
CompatibilityLevel                : 0
DisableSharingForNonOwnersStatus  :
Url                               : https://mycompany.sharepoint.com/
LocaleId                          : 3082
LockState                         : UnLock
Owner                             :
StorageQuota                      : 1048576
StorageQuotaWarningLevel          : 0
ResourceQuota                     : 300
ResourceQuotaWarningLevel         : 255
Template                          : EHS#1
Title                             :
AllowSelfServiceUpgrade           : False
DenyAddAndCustomizePages          : Unknown
PWAEnabled                        : Unknown
SharingCapability                 : ExternalUserAndGuestSharing
SandboxedCodeActivationCapability : Unknown
DisableCompanyWideSharingLinks    : Unknown
StorageQuotaType                  :

What can I do to disable DenyAddAndCustomizePages property?

2 Answers 2

0

You can do it from O365 Admin center

enter image description here

Sorry for bad screen

2
  • but then you have to wait about 24 hours
    – user53301
    Apr 14, 2016 at 12:45
  • Thanks for the response, I know it, but I didn't want to wait for 24 hours. Why there is no property set method. I recall I could do it in the past. Apr 14, 2016 at 14:11
-1

Have you tried running:

Set-SPOsite https://mycompany.sharepoint.com -DenyAddAndCustomizePages 0

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .