2

When i edit page i cannot see page layout option in ribbon. I have checked that i have enabled feature SharePoint Server Publishing Infrastructure enabled both on site collections and site features.

What could be other issue? I have many pages in pagelayouts and they are published.

3
  • can you share your sample URL where you did not get it?
    – Hardik
    Apr 13, 2016 at 9:51
  • @Hardik what you mean?
    – Happy
    Apr 13, 2016 at 9:54
  • Can you check the exact error you are getting while creating the page? You can find the error using Correlation ID with the help of ULSVIEWER? If you can post the error than I can help you further.
    – Hardik
    Apr 14, 2016 at 9:03

1 Answer 1

1

If you are trying to change the page layout for pre-created SharePoint default page than you will not get it (If you are changing the page layout of the page which are created before activating feature than it will not work.).

The issue is that the feature is not enabled that allows the layouts.

To fix the issue go to Site Actions -> Site Settings in the upper right corner.

Under "Site Collection Administration" click on "Site Collection Features".

Look for "SharePoint Server Publishing Infrastructure" and activate it. It might take a moment to load.

Next return to "Site Settings" and click on "Manage Site Features"

Look for "SharePoint Server Publishing" and activate it. It might take a moment to load.

Note:

If you don't have the Site Collection Administration section of your settings you can try skipping to the next part. However if the site collection does not have this enabled then you will get an error when trying to activate it on the site. You will need to get into the site collection's options.

After making a new site you can go into Site Features and again enable SharePoint Server Publishing. This worked fine on a blank webpage so a publishing page/site is not necessary.

6
  • i am gettting error when i click on "Page layouts and site templates". the page simply crashes
    – Happy
    Apr 13, 2016 at 10:03
  • under site settings?
    – Hardik
    Apr 13, 2016 at 10:04
  • yes under site settings
    – Happy
    Apr 13, 2016 at 10:36
  • Why you are editing that page?
    – Hardik
    Apr 13, 2016 at 10:50
  • i am not editing that page... i just clicked there.. also when i go to Pages under site contents and try to add page then also page is crashing
    – Happy
    Apr 13, 2016 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.