0

I am using SharePoint 2013 Enterprise version. I have four server in the farm. From where, two are Front End Server where web application is installed and they are behind load balancing. I have other two server which act as service application server.

For example :-

  1. VMSPFE01 (web application server, behind load balance)
  2. VMSPFE02 (web application server, behind load balance)
  3. VMSPAP01 (service application server)
  4. VMSPAP02 (service application server)

My SharePoint is access on http://xyz.company.com

Now I installed Workflow Manager anc configure on server 1,2,4

  1. I can see web application on IIS and pool are also running. Screen as below enter image description here
  2. I can see that all services are running properly, which are

    Service Bus Gateway , Service Bus Message Broker, Windows Fabric Host Service, Workflow Manager Backend

  3. I have only one issue while running below command on cmdlet, it throws error

    Register-SPWorkflowService -SPSite "http://xyz.company.com" -WorkflowHostUri "http://xyz.company.com:12291" -AllowOAuthHttp

enter image description here

  1. My central admin service application screen shot enter image description here And also I cannot see SharePoint 2013 Workflow option in the SharePoint Desinger

How can I solve the issue

  • What error does it throw? – Christoffer Apr 12 '16 at 8:51
  • updated my post with error screen shot. Another thing what I found is that I don't have any site like xyz.company.com:12291/Sharepoint – Milind Apr 12 '16 at 8:55
  • Is the workflow manager proxy added to the central admin proxy group? Does the service application proxy exist under service applications in Central admin? – Christoffer Apr 12 '16 at 8:58
  • Yes it have, I also added that screen in my original post – Milind Apr 12 '16 at 9:02
  • What does it say if you click on it? Is it connected or not? – Christoffer Apr 12 '16 at 9:02
0

I found the issue. When I fire below cmdlet

Register-SPWorkflowService -SPSite "http://xyz.company.com" -WorkflowHostUri "http://xyz.company.com:12291" -AllowOAuthHttp

it always throw error. After lot of search, I found that http://xyz.company.com was not accessible from server itself. So what i did is, I added host file entry in the server and it stop throwing error.

Now another issue that after finishing above error still, I cannot see SharePoint 2013 option in the SharePoint designer.

For above issue I found that as http://xyz.company.com is load balance and load balance was configure on 80 port not 12290 port. I have inform my network team to open it.

I will inform you once they open port what was the result.

**Update**

Until now 12290 port is not open but the option of SharePoint 2013 in SharePoint designer start coming. So no need to open the port 12290. Main issue was for URL was not accessible within the server

Hope it can help somebody

-1

Couple of things to check

  1. Workflow Manager has Hidden Dependencies on App Management Service and Site Subscription service. You just need to provision those and then try to register it. You can provision App management Service from Central admin and use the below code for Site subscription service.

    $manaccount = Get-SPManagedAccount Domain\username
    
    $appPoolService = New-SPServiceApplicationPool -Name "SS-AppPool" -Account $manaccount
    
    $appService = New-SPSubscriptionSettingsServiceApplication -ApplicationPool $appPoolService -Name SettingsServiceApp -DatabaseName "SS-ContentDB"
    
    $proxyService = New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $appService
    
  2. Make sure Workflow Client Installed on all the SharePoint server( if WF Manager not installed).

  • Well I don't have App Management Service and Site Subscription service But still it works. I have given detail explanation in my answer why it was not working. – Milind Apr 13 '16 at 5:37
  • yes, you will get the 2013 workflow but when you try to publish SharePoint 2013 designer workflow at that time it will fail and in background both service required.social.technet.microsoft.com/Forums/office/en-US/… – Waqas Sarwar MVP Apr 13 '16 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.