0

We have patched two SP2013 farms. One is standard another is enterprise. Both farm's copy-spsite no longer work after patch. The patches are not cumulative update download from SharePoint update official site. The patches were applied by our infrastructure team who have no knowledge on SharePoint.....

After patch it was down but it is fixed after we complete Configuration wizard. Now the Configuration database version is 15.0.4763.1000.

We do not find any obvious problem beside Copy-SPsite no longer do this job. We used to use copy-spsite to duplicate a site collection towards a blank new content db. For now, when we run the same Powershell it looks ok. However actually no content is copied over. In the CA the new site collection is listed but no property is shown when click it. When browse the site it shows:

HTTP/1.1 200 OK
Server: Microsoft-IIS/7.5
Date: Tue, 12 Apr 2016 02:00:09 GMT
Connection: close

We cannot remove the problematic site collection by remove-spsite. It throw error:

Remove-SPSite : <nativehr>0x80070003</nativehr><nativestack></nativestack>

We have to delete it with follow script:

$site = Get-SPSite http://siteurl
$siteId = $site.Id
$siteDatabase = $site.ContentDatabase 
$siteDatabase.ForceDeleteSite($siteId, $false, $false)

We thought maybe SQL server patch level not match. Last week we patched it towards SQL Server 2008 R2 Service Pack 3 and still the same.

Backup-spsite/restore-spsite can do the job. But I wonder why copy-spsite no longer work (and not throwing any error).

How can I fix it? I am considering patch the SharePoint farm but I want to know which level I need. Thanks for your input.

  • new content Database on same SQL server? – Waqas Sarwar MVP Apr 12 '16 at 3:02
  • Yes. New CD on same SQL server. – Mark L Apr 12 '16 at 3:21
  • How you creating the Content Database? via Central admin or powersehll? have you tried to create new site collection in NEW CD either Powershell of Central admin? for me it is more database issue then copy-spsite. – Waqas Sarwar MVP Apr 12 '16 at 3:29
  • I create new CD with PowerShell. I have tried restore the site to this new CD and works. Also I have tried several times using copy-spsite and problem reproduce every time. However all my test is on same SQL server. – Mark L Apr 12 '16 at 3:49
  • 1
    You mention that the patches were not CU's from the official MS sites, were did they got the patches from? Windows update? As Mike mentions below, make sure that the patches were really applied and that the wizard were run succesfully on each server, on at a time afterwards. – Christoffer Apr 12 '16 at 7:06
1

I'd try to apply the patches yourself, in order. Install on CA server first, one at a time for each server. Then run the psconfig on the CA server, one at a time, then each server after that. The patches being installed by non-SharePoint guys is a huge red-flag since it's a specific process to it. Was it done to all servers? Did they install and run psconfig on the CA server first? Did they use the farm account? These are things to consider.

I'd patch the servers yourself up to February CU (I always patch a CU behind). https://support.microsoft.com/en-us/kb/3114726

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.