I have a SharePoint 2013 platform and have several workflows created using SharePoint Designer. I have workflows using 2013 and 2010 engine.

The workflows I created using 2010 are being executed several times on every edit.

How can I stop this and have the 2010 workflow execute only once upon editing the item?

  • Is it executed on edit? You can chech in version history how many times the item eas edited... Apr 11, 2016 at 18:20
  • 1
    also check if your workflow is editing the item itself
    – Prakash
    Apr 11, 2016 at 18:20

2 Answers 2


I was facing the same issue. There was multiple instances of versions of the same workflow in my case. Following Steps helped me resolving this issue.

  1. Go To "list Settings"
  2. Go To "Workflow settings"
  3. Go To "Remove, Block, or Restore a Workflow" and you will get following screen enter image description here
  4. Remove Un-wanted Instances
  5. Done
  • thank you Rohit! the removal of previous versions solved the problem! Now how do i prevent the workflow from creating versions? I notice it creates a version every time i change and publish it in designer.
    – Ehj Daria
    Apr 15, 2016 at 20:51
  • @EhjDaria: Each time a new workflow is published within SPD, a new instance is added. What this means is that each time a workflow is published, it overwrites a previous version but the previous versions are not removed. This is to allow any items that still have "in-progress" workflows to complete successfully. Where new Item will automatically start using new version. Apr 16, 2016 at 12:38
  • @EhjDaria: Could you please create new a item and edit this item and check if workflow is working or not ? I think you should not face the same problem now. Apr 16, 2016 at 12:47
  • I already removed the previous version and it worked fine after. But the next day, i am experiencing it again. I checked the settings and it only has one workflow. the workflow history states as well that the same workflow was executed several times at the same time
    – Ehj Daria
    Apr 20, 2016 at 13:58

Not sure if I understood you correctly, but what I did when I had similar problem (WF 2010 starts every time user edited item) I created additional column Yes/No field. Default value was No. Example of column: Is workflow triggered? Default value No.

At the beginning of workflow put If clause to check your column, If value of Yes/No column is No, workflow will be executed inside the IF clause, but if the value is Yes, than workflow will skip it and go to the end. At the end of the workflow just put update of Yes/No column to Yes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.